Fly Fishing Forum - Reply to Topic
Gear Talk - Fly Stuff Spoken Here Sage advice & fresh perspectives

Thread: Stuck Litespeed Spools Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Fly Fishing Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options
Rate Thread
If you like, you can add a score for this thread.

Topic Review (Newest First)
05-24-2005 07:42 AM
chromer I have retired mine to freshwater use. Straits and Puget Sound use killed them once already. Luckily I need small spey reels.

It's a fundamental design fault and it's only a matter of time.
05-24-2005 06:37 AM
JimW Stan, Look up a few post, I said the same thing a few months back. Been towed around many times in the yak and when it was working, it was silky smooth. It was my goto reel for anything that really pulls, big blues, albies, bass in a rip. Now I'm always going to be wondering if it's going to fail while in use. If the spool gets stuck, well I can still fish but if the drag fails....
Hope your luck holds.
05-23-2005 07:25 PM
Stan I used my Litespeed 4 a lot from my kayak. It's usually always sitting in a puddle of saltwater and I rinse it rarely. Never had a problem with changing spools or the very nice smooth drag. According to the papers I got with the reel it says:
If you change spools frequently, a small amount of high melting point grease should be applied to the outboard O-Ring periodically.
I apply some once in a while and maybe that's the reason why I'm not experiencing the same problem some of you are having.
05-23-2005 02:40 PM
JimW I crack out the Litespeed 4 to do a little casting practice with the Atlantis a couple weeks ago and much to my dismay the drag is completely non functional. I'm just glad I discoverved this now and not when I on a fishing trip.
My buddy got a velocity about 6 months ago and he's got the stuck spool syndrome. We might as well be fishing Pluegers. The warranty deptarment hasn't given me any crap but it's a month minimum before it even ships to me, hopefully on some priority service for the $20 I had to fork over to have them fix it.

12-24-2004 09:26 PM
Smolt Well, I have put a light film of the anti-corrsion spray I mentione in a prior post on this thread on the spindle of my Lamson LS2. No problem with slipping and it should protect against corrsion. Maybe this is an anwer to the problems noted above.

The product is not a sponsor, so end me a PM if you want the name of the product.

Happy Holidays
12-24-2004 09:06 PM
E. simulans I have the Lamson Litespeed 2. While the spool has not stuck, corrosion of the bearing cartidge is an ongoing problem. Water gets entrapped in the "sealed" drag housing, and the clutch/bearing cartridge rusts. They sent me a new cartridge, but now its rusting. I wish Lamson would improve the corrosion resistance of this part.

I've also had a mysterious tightening of the spool - spindel had to be replaced - and a non-linearity to the drag - drag had to be replaced.

I love the reel, but I am growing weary of the unreliability. Repairs take forever (months).

As for the LP series, dropping them was poor idea IMHO. Having just used a buddy's LP3, I kick myself for not buying them when they were available. What a block of a reel with great action and sound. Another great Lamson reel was the cork drag/ draw bar model - one was called the Steelhead. Again I kick myself for not picking one up.

I'm not too impressed with the current Lamson/ Waterworks offerings. Bring back the oldies.
12-24-2004 01:37 PM
troutslayerny
Quote:
Originally Posted by jamie
With the high cost of good fishing equipment I like to factor customer service into the value equation.
Yes, Jamie, I agree. The idea of paying for quality and warranty is what appeals to me. I have a Sci Angler system 1 for just as long as the Lamson. No prolems there--and it gets (or was fished) as much or more than the Lamson. I do have an LP (no longer in production ) and it hasn't given me a single problem. Lamson said it had too many problems, that's why they discontinued it. All this could be luck of the draw...

When I worked as a shop pro in Montana, I sold gear because of the quality and warranty. Seems like paying less to get a die-cast reel and a few more ounces of weight may be the way to go. Old-timers I know would not live or fish without their Pfluegars...there's something to be said for experience...
12-24-2004 04:10 AM
jamie
Interesting

Thanks for the feedback. With the high cost of good fishing equipment I like to factor customer service into the value equation.
12-23-2004 08:41 PM
debarb My experience mirrors troutslayerny's. Cordial, but nothing that would inspire loyalty.
12-23-2004 07:37 PM
troutslayerny
Quote:
Originally Posted by jamie
How do you find Lamsons customer service. Always interested to hear.
The customer service manager is a nice. However, when I asked for a replacement--and I asked for a completely different reel--he said that they would look at mine and decide what needed to be done. I explained that I no longer wanted the Lightspeed because of this recurring problem. He stuck to the reel I have.

So I would have to say my two dealings with Lamson have been cordial but not satisfactory. I guess I did not fully understand the warranty...

I will be buying Galvan reels in the future. That is unless someone here suggests a brand other than Orvis.
12-22-2004 09:09 AM
Smolt Has anyone tried applying anything on the spindle to prevent corrosionn. I use one such product -- I do not want to mention its name, but email me if you are interested -- on all my reels. Since I started using it, I have fished the salt only once. Consequently, my experience should not be etched in stone, but the two reels I used have not shown any signs of saltwater wear.

I am tempted to try it on the LS2 I just acquired, but am a bit concerned that it might make the spindle so slick that it will start slipping. Well, having said all that, I have decided to give it a try anyway. I will post again in a week or so to let you know whether there were any problems.

I am told by the distributor of the product that it will not adversely affect plastic or rubber, so I am not worried about the seals/o-rings. Time will tell.
12-22-2004 06:34 AM
BigDave My .02:

If you change spools frequently Lamson Velocity/Litespeed is not a good reel. If you expose the spindle to salt/moisture and then snap it back in the clutch the moisture is sealed in which leads to corrosion. The same principle that keeps water out will also keep it in.

If you never change spools you will probably have no problem. This is my experience at least. I have a trout sized Litepseed which has been dropped/dunked countless times and looks like brand new inside. However the spool almost never comes off.

From now on I will bite the bullet and go with Bauer/Abel/Tibor for SW reels.
12-22-2004 03:35 AM
jamie
No problems with mine

I use a 3.5 pretty regularly in the salt with my heads. Like Jim I tend to give my gear a rinse quite regularly.

How do you find Lamsons customer service. Always interested to hear. In the past I have received excellent customer service from Sage and Old Florida dealing with problems and returning good promptly to the UK.
12-21-2004 06:34 PM
JimW I don't change the spool very often at all. I run the sinking line on the LS4 for the boat and bring another rod for clear intermediate if I think it will be of use. I do pull it apart and rinse it a few times a year and hose it down every other trip or so. I should take better care of it but you might be onto something. Since I don't take it apart very often perhaps moisture is not getting past the seal and the spindle is better protected.
12-21-2004 04:17 PM
debarb I don't have stuck spools, but my LS 4 drag is sticking yet again, and they want me to send it back for yet another $20 and shipping. Hell with it. I'm going over to Hardy St. Johns & Marquis, and Tibor.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:16 AM.



Copyright Flyfishingforum.com (All Rights Reserved)