U-40 Rod Bond not setting up [Archive] - Fly Fishing Forum

: U-40 Rod Bond not setting up


Darren Evans
09-11-2003, 11:26 PM
Mixed equal parts and applied it to reel seat assembly and cork handle. It's been about an hour and a half, and the stuff is still not setting up. This is my first experience with RodBond. What is the standard time for this stuff to set up?

loco_alto
09-12-2003, 01:54 AM
It sets slowly - which I consider a good long working time.

I set it up and leave it alone, good to go the next morning. I believe the official word is 24 hours to cure, and 48 hours to fish.

JimW
09-12-2003, 02:37 PM
I'm not familiar with the rod bond but I've used u-40 for coating guide wraps. I use the flex coat rod builders epoxy for the reel seat, it sets up in a couple hours and cures in a day or so. I don't know about using a thin epoxy for the reel seat.

I'd give it plenty of time and not twist it during curing or you'll end up with one of those rotating reel seats.

Remember that the temperature and humidity will have a huge effect on drying time. Dry and Hot is what you want.

flytyer
09-13-2003, 01:04 AM
Like loco_alto said, "It sets slowly".

This is the rod bonding glue that I use because of its thick, paste-like consistency it stays where you put it before it is cured. However, you must leave it set overnight without moving the parts or they will be out of alignment. And never take it fishing until at least 48 hours have passed since it gluing.

Darren Evans
09-13-2003, 12:09 PM
Thanks for all the feedback. I should have asked here first before I used the stuff. You gents are good people. :)